summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornicolargo <nicolargo@nicolargo-boulot.(none)>2011-12-05 10:26:36 +0100
committernicolargo <nicolargo@nicolargo-boulot.(none)>2011-12-05 10:26:36 +0100
commitf0f484ed1d00e77cde57808681d45179c3550b0e (patch)
treef658758e611ff9dad890df863f4607b3a5275142 /setup.py
parentd418678718c53f12bcb173e4ad1a969c122c9842 (diff)
Add setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 24 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..a0faa149
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,24 @@
+#!/usr/bin/env python
+
+import os
+from distutils.core import setup
+
+# Utility function to read the README file.
+# Used for the long_description. It's nice, because now 1) we have a top level
+# README file and 2) it's easier to type in the README file than to put a raw
+# string in below ...
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup( name='Glances',
+ version='1.1',
+ description='CLI curses-based monitoring tools',
+ author='Nicolas Hennion',
+ author_email='nicolas@nicolargo.com',
+ license = "LGPL",
+ keywords = "cli curse monitoring system",
+ long_description=read('README'),
+ url='https://github.com/nicolargo/glances',
+ packages=['src'],
+ install_requires=['statgrab>=0.5']
+)