summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNicolas Hennion <nicolas@nicolargo.com>2012-07-06 14:03:32 +0200
committerNicolas Hennion <nicolas@nicolargo.com>2012-07-06 14:03:32 +0200
commit73a324c6a9a92fc94317db6e8c2dd387a9607e67 (patch)
treedf7c3f3c61f292c38fe2fe5bce92965cf30919f2 /setup.py
parent1e04f70675801ee779709cb53c8e4f3ef0640a7e (diff)
parentcfcf6bf3c8ef06e11ca27e25b4931794b507e46b (diff)
version 1.4v1.4
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py58
1 files changed, 38 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index cdcc6434..cfa15009 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,25 +1,43 @@
#!/usr/bin/env python
-import os
-from distutils.core import setup
+from glob import glob
+from os.path import dirname
-# Utility function to read the README file.
-# Used for the long_description. It's nice, because now 1) we have a top level
-# README file and 2) it's easier to type in the README file than to put a raw
-# string in below ...
-def read(fname):
- return open(os.path.join(os.path.dirname(__file__), fname)).read()
+from setuptools import setup
-setup( name='Glances',
- version='1.3.7',
- download_url='https://github.com/downloads/nicolargo/glances/glances-1.3.7.tar.gz',
- url='https://github.com/nicolargo/glances',
- description='CLI curses-based monitoring tool',
- author='Nicolas Hennion',
- author_email='nicolas@nicolargo.com',
- license = "LGPL",
- keywords = "cli curse monitoring system",
- long_description=read('README'),
- packages=['src'],
- install_requires=['pystatgrab>=0.5']
+data_files = [
+ ('share/man/man1', ['man/glances.1']),
+ ('share/doc/glances', ['README',
+ 'README-fr',
+ 'COPYING',
+ 'AUTHORS',
+ 'ChangeLog',
+ 'NEWS',
+ 'screenshot.png']),
+ ('share/doc/glances/doc', glob('doc/*.png')),
+ ('share/glances/html', glob('src/html/*.html')),
+ ('share/glances/html/css', glob('src/css/*.css')),
+ ('share/glances/html/img', glob('src/img/*.png')),
+]
+for mo in glob('i18n/*/LC_MESSAGES/*.mo'):
+ data_files.append((dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
+
+setup(name='Glances',
+ version='1.4',
+ download_url='https://github.com/downloads/nicolargo/glances/glances-1.4.tar.gz',
+ url='https://github.com/nicolargo/glances',
+ description='CLI curses-based monitoring tool',
+ author='Nicolas Hennion',
+ author_email='nicolas@nicolargo.com',
+ license="LGPL",
+ keywords="cli curses monitoring system",
+ long_description=open('README').read(),
+ install_requires=['psutil>=0.4.1'],
+ packages=['glances'],
+ extras_require = {
+ 'HTML': ['jinja2>=2.0'],
+ },
+ include_package_data=True,
+ data_files=data_files,
+ entry_points={"console_scripts": ["glances = glances.glances:main"]},
)