summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlessio Sergi <al3hex@gmail.com>2017-01-22 16:50:45 +0100
committerAlessio Sergi <al3hex@gmail.com>2017-01-22 16:50:45 +0100
commitbbaf40d60ac22b450f43f1097042489172b5664f (patch)
tree9cdd61e2f0f70f9aeb70fb551d9cff5a78407d6e /setup.py
parentac9ad9ca40f847cf3082076697ac47e1594e02a4 (diff)
setup.py: fix py3sensors installation and conditionalize scandir dependency
- scandir package is only needed for Python < 3.5. - the name of extras are now lower case (easier to type/read). Note: setuptools >= 18.0 is required.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 16 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 0ed41b72..8260f8a9 100755
--- a/setup.py
+++ b/setup.py
@@ -78,21 +78,22 @@ setup(
keywords="cli curses monitoring system",
install_requires=get_install_requires(),
extras_require={
- 'ACTION': ['pystache'],
- 'BATINFO': ['batinfo'],
- 'BROWSER': ['zeroconf>=0.17'],
- 'CPUINFO': ['py-cpuinfo'],
- 'CHART': ['matplotlib'],
- 'DOCKER': ['docker>=2.0.2'],
- 'EXPORT': ['bernhard', 'cassandra-driver', 'couchdb', 'elasticsearch', 'influxdb>=1.0.0', 'pika', 'potsdb', 'pyzmq', 'statsd'],
- 'FOLDERS': ['scandir'],
- 'GPU': ['nvidia-ml-py'],
- 'IP': ['netifaces'],
- 'RAID': ['pymdstat'],
- 'SENSORS': ['py3sensors'],
- 'SNMP': ['pysnmp'],
- 'WEB': ['bottle', 'requests'],
- 'WIFI': ['wifi']
+ 'action': ['pystache'],
+ 'batinfo': ['batinfo'],
+ 'browser': ['zeroconf>=0.17'],
+ 'cpuinfo': ['py-cpuinfo'],
+ 'chart': ['matplotlib'],
+ 'docker': ['docker>=2.0.0'],
+ 'export': ['bernhard', 'cassandra-driver', 'couchdb', 'elasticsearch',
+ 'influxdb>=1.0.0', 'pika', 'potsdb', 'pyzmq', 'statsd'],
+ 'folders:python_version<"3.5"': ['scandir'],
+ 'gpu': ['nvidia-ml-py'],
+ 'ip': ['netifaces'],
+ 'raid': ['pymdstat'],
+ 'sensors': ['https://bitbucket.org/gleb_zhulik/py3sensors/get/tip.zip'],
+ 'snmp': ['pysnmp'],
+ 'web': ['bottle', 'requests'],
+ 'wifi': ['wifi']
},
packages=['glances'],
include_package_data=True,