summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNicolargo <nicolas@nicolargo.com>2014-06-14 09:44:02 +0200
committerNicolargo <nicolas@nicolargo.com>2014-06-14 09:44:02 +0200
commitcf480a9b410e2d2d35eb0c7cbd8d242133797bf5 (patch)
tree90369c6e48c3a5f6c82d4da2f102ddb1abddb8c7 /setup.py
parent4881fb6c5223456ffdd2e909fb9db828b096d06c (diff)
parent8b637e91f10d41093030a2d8786ef8cdabb443e9 (diff)
Merge v2.0 release branch
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py69
1 files changed, 40 insertions, 29 deletions
diff --git a/setup.py b/setup.py
index 0e5c6dd1..7fae26f2 100755
--- a/setup.py
+++ b/setup.py
@@ -6,52 +6,63 @@ import sys
from setuptools import setup
-data_files = [
- ('share/doc/glances', ['AUTHORS', 'COPYING', 'NEWS', 'README.rst',
- 'conf/glances.conf', 'docs/glances-doc.html']),
- ('share/doc/glances/images', glob.glob('docs/images/*.png')),
- ('share/man/man1', ['man/glances.1'])
-]
-if hasattr(sys, 'real_prefix') or 'bsd' in sys.platform:
- conf_path = os.path.join(sys.prefix, 'etc', 'glances')
-elif not hasattr(sys, 'real_prefix') and 'linux' in sys.platform:
- conf_path = os.path.join('/etc', 'glances')
-elif 'darwin' in sys.platform:
- conf_path = os.path.join('/usr/local', 'etc', 'glances')
-elif 'win32' in sys.platform:
- conf_path = os.path.join(os.environ.get('APPDATA'), 'glances')
-data_files.append((conf_path, ['conf/glances.conf']))
+def get_data_files():
+ data_files = [
+ ('share/doc/glances', ['AUTHORS', 'COPYING', 'NEWS', 'README.rst',
+ 'conf/glances.conf', 'docs/glances-doc.html']),
+ ('share/doc/glances/images', glob.glob('docs/images/*.png')),
+ ('share/man/man1', ['man/glances.1'])
+ ]
+
+ if hasattr(sys, 'real_prefix') or 'bsd' in sys.platform:
+ conf_path = os.path.join(sys.prefix, 'etc', 'glances')
+ elif not hasattr(sys, 'real_prefix') and 'linux' in sys.platform:
+ conf_path = os.path.join('/etc', 'glances')
+ elif 'darwin' in sys.platform:
+ conf_path = os.path.join('/usr/local', 'etc', 'glances')
+ elif 'win32' in sys.platform:
+ conf_path = os.path.join(os.environ.get('APPDATA'), 'glances')
+ data_files.append((conf_path, ['conf/glances.conf']))
+
+ for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
+ data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
+
+ return data_files
+
-for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
- data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
+def get_requires():
+ requires = ['psutil>=2.0.0']
+ if sys.platform.startswith('win'):
+ requires += ['colorconsole']
+ if sys.version_info < (2, 7):
+ requires += ['argparse']
-requires = ['psutil>=0.5.1']
-if sys.platform.startswith('win'):
- requires += ['colorconsole']
+ return requires
setup(
name='Glances',
- version='1.7.7',
+ version='2.0',
description="A cross-platform curses-based monitoring tool",
long_description=open('README.rst').read(),
author='Nicolas Hennion',
author_email='nicolas@nicolargo.com',
url='https://github.com/nicolargo/glances',
- # download_url='https://s3.amazonaws.com/glances/glances-1.7.7.tar.gz',
+ # download_url='https://s3.amazonaws.com/glances/glances-2.0.tar.gz',
license="LGPL",
keywords="cli curses monitoring system",
- install_requires=requires,
+ install_requires=get_requires(),
extras_require={
- 'HTML': ['jinja2'],
- 'SENSORS': ['pysensors'],
- 'BATINFO': ['batinfo']
+ 'WEB': ['bottle'],
+ 'SENSORS': ['py3sensors'],
+ 'BATINFO': ['batinfo'],
+ 'SNMP': ['pysnmp']
},
packages=['glances'],
include_package_data=True,
- data_files=data_files,
- test_suite="glances.tests",
- entry_points={"console_scripts": ["glances=glances.glances:main"]},
+ data_files=get_data_files(),
+ test_suite="unitest.py",
+ entry_points={"console_scripts": ["glances=glances:main"]},
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Console :: Curses',