summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlessio Sergi <al3hex@gmail.com>2014-05-11 17:11:17 +0200
committerAlessio Sergi <al3hex@gmail.com>2014-05-11 17:11:17 +0200
commitb6339ed76dee2d03ee5d1c8b6c2731ec52f0be9f (patch)
treed8c06256bea6fed4462303bcf58008c2cabfb43b /setup.py
parent535793da058b607c92c73b84cf470377d8dd5b59 (diff)
Small fixes and improvements
README.rst: Add Slackware http://slackbuilds.org/repository/14.1/system/glances/
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 1fe0f979..c09ae40e 100755
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,8 @@
#!/usr/bin/env python
+import glob
import os
import sys
-import glob
from setuptools import setup
@@ -26,10 +26,9 @@ data_files.append((conf_path, ['conf/glances.conf']))
for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
+requires = ['psutil>=0.5.1']
if sys.platform.startswith('win'):
- requires = ['psutil>=0.5.1', 'colorconsole==0.6']
-else:
- requires = ['psutil>=0.5.1']
+ requires += ['colorconsole']
setup(
name='Glances',
@@ -66,6 +65,7 @@ setup(
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3'
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4'
]
)