summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornicolargo <nicolashennion@gmail.com>2016-03-13 16:57:16 +0100
committernicolargo <nicolashennion@gmail.com>2016-03-13 16:57:16 +0100
commitf863ec5ece72694702a5775a2f2950217ca33493 (patch)
tree63192f47271b489d3ad5fcc32e45539454c42ae7 /setup.py
parent621278b1109e621538f5187e7a6c6e26113d3743 (diff)
Correct some minor PEP8 error
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7ca5e457..a22a465a 100755
--- a/setup.py
+++ b/setup.py
@@ -9,6 +9,7 @@ if sys.version_info < (2, 6) or (3, 0) <= sys.version_info < (3, 3):
print('Glances requires at least Python 2.6 or 3.3 to run.')
sys.exit(1)
+
class tests(Command):
user_options = []
@@ -27,6 +28,7 @@ class tests(Command):
raise SystemExit(ret)
raise SystemExit(0)
+
def get_data_files():
data_files = [
('share/doc/glances', ['AUTHORS', 'COPYING', 'NEWS', 'README.rst',
@@ -36,6 +38,7 @@ def get_data_files():
return data_files
+
def get_requires():
requires = ['psutil>=2.0.0']
if sys.platform.startswith('win'):