summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlessio Sergi <al3hex@gmail.com>2018-01-26 19:03:33 +0100
committerAlessio Sergi <al3hex@gmail.com>2018-01-26 19:03:33 +0100
commit4e606f46503e3bfb1c1f5b8ddc0f043e8fa8db06 (patch)
treea4ffbb80768a69f442159d11538421cbac3fbe2f /setup.py
parent524babd3d7cb574409baaedc41098be592fa5122 (diff)
Drop support for EOL Python 3.3
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 08a831a4..b5d11b6d 100755
--- a/setup.py
+++ b/setup.py
@@ -9,8 +9,8 @@ from io import open
from setuptools import setup, Command
-if sys.version_info < (2, 7) or (3, 0) <= sys.version_info < (3, 3):
- print('Glances requires at least Python 2.7 or 3.3 to run.')
+if sys.version_info < (2, 7) or (3, 0) <= sys.version_info < (3, 4):
+ print('Glances requires at least Python 2.7 or 3.4 to run.')
sys.exit(1)
@@ -113,7 +113,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',