summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornicolargo <nicolas@nicolargo.com>2023-11-26 10:02:30 +0100
committernicolargo <nicolas@nicolargo.com>2023-11-26 10:02:30 +0100
commitbcf4ce45fc0394ea64d35062c97a5e5dfdedd29b (patch)
treee22f75fe8f89b6b1d306ce81629b4d7ce87ae642 /setup.py
parent36ed96b05a6627aa8eeb4f8afbd7a268ce0aa572 (diff)
Rename any reference to Bottle in doc and dep file. Ready to refactor the main glances_restful_api.py file.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 092a3a82..6049b513 100755
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,8 @@ def get_install_requires():
'ujson>=5.4.0',
]
if sys.platform.startswith('win'):
- requires.append('bottle')
+ requires.append('fastapi')
+ requires.append('uvicorn')
requires.append('requests')
return requires
@@ -67,7 +68,7 @@ def get_install_extras_require():
'smart': ['pySMART.smartx'],
'snmp': ['pysnmp'],
'sparklines': ['sparklines'],
- 'web': ['bottle', 'requests'],
+ 'web': ['fastapi', 'uvicorn', 'requests'],
'wifi': ['wifi']
}
if sys.platform.startswith('linux'):
@@ -123,7 +124,7 @@ setup(
'Development Status :: 5 - Production/Stable',
'Environment :: Console :: Curses',
'Environment :: Web Environment',
- 'Framework :: Bottle',
+ 'Framework :: FastAPI',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',
'Intended Audience :: System Administrators',