summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlessio Sergi <al3hex@gmail.com>2014-12-04 10:49:49 +0100
committerAlessio Sergi <al3hex@gmail.com>2014-12-04 10:49:49 +0100
commited0ef18456ac5022232281051c087f77fa1dfe23 (patch)
treea09e20eba162fc9b90fa6473df08e78acedb0571 /setup.py
parentdafcc65d5ce85e850c7fdc3e90f357cc0f9b13b0 (diff)
setup.py: zeroconf and netifaces are optional dependencies
Move them to extras_require.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1f56119f..060342c2 100755
--- a/setup.py
+++ b/setup.py
@@ -40,9 +40,6 @@ def get_data_files():
def get_requires():
requires = ['psutil>=2.0.0']
- if sys.platform.startswith('linux') or sys.platform.startswith('darwin'):
- requires += ['zeroconf>=0.16']
- requires += ['netifaces']
if sys.platform.startswith('win'):
requires += ['colorconsole']
if sys.version_info < (2, 7):
@@ -67,7 +64,8 @@ setup(
'SENSORS': ['py3sensors'],
'BATINFO': ['batinfo'],
'SNMP': ['pysnmp'],
- 'CHART': ['matplotlib']
+ 'CHART': ['matplotlib'],
+ 'BROWSER': ['zeroconf>=0.16', 'netifaces']
},
packages=['glances'],
include_package_data=True,