summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlessio Sergi <al3hex@gmail.com>2016-12-26 19:00:00 +0100
committerAlessio Sergi <al3hex@gmail.com>2016-12-26 19:01:46 +0100
commit723519f6a96d422e863708f4d96fd07f5511eb2b (patch)
tree494c2259ef5d8537d9e5e2f2a0ca301b765e7190 /setup.py
parentcefa8b06cefbe3ab3a62bdaa58b2d4ca94a85ddb (diff)
setup.py: get_requires() no longer needed
We dropped support for Python 2.6 and curses interface on Windows.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 1 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 4ca8722d..2e2bf0b0 100755
--- a/setup.py
+++ b/setup.py
@@ -37,12 +37,6 @@ def get_data_files():
return data_files
-def get_requires():
- requires = ['psutil>=2.0.0']
-
- return requires
-
-
class tests(Command):
user_options = []
@@ -74,7 +68,7 @@ setup(
url='https://github.com/nicolargo/glances',
license="LGPL",
keywords="cli curses monitoring system",
- install_requires=get_requires(),
+ install_requires=['psutil>=2.0.0'],
extras_require={
'WEB': ['bottle', 'requests'],
'SENSORS': ['py3sensors'],