summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMarkus Roth <mail@rothmark.us>2014-03-16 05:17:57 +0100
committerMarkus Roth <mail@rothmark.us>2014-03-16 05:17:57 +0100
commit49ba692154ffe2d4e55fcc62b53d95d209d071fd (patch)
treec03540a959b3eef49715dad0366d607629f95cfa /setup.py
parentbfa9089e5f2540b0762a4b3a23d6c24534045f16 (diff)
Adapt to psutil 2.0.0 API.
API changed. https://psutil.googlecode.com/hg/HISTORY Tested with 0.5.1, 1.2.1, 2.0.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index cf6c25bd..695fcb91 100755
--- a/setup.py
+++ b/setup.py
@@ -27,9 +27,9 @@ for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
if sys.platform.startswith('win'):
- requires = ['psutil>=0.5.1,<=1.2.1', 'colorconsole==0.6']
+ requires = ['psutil>=0.5.1,<=2.0.0', 'colorconsole==0.6']
else:
- requires = ['psutil>=0.5.1,<=1.2.1']
+ requires = ['psutil>=0.5.1,<=2.0.0']
setup(
name='Glances',