summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRui Chen <rui@chenrui.dev>2023-01-14 15:02:19 -0500
committerRui Chen <rui@chenrui.dev>2023-01-14 15:02:19 -0500
commitf21750ca489bf64e618aa4337c19813a955f3f82 (patch)
tree29a9d225bb48292a889c7b90b3ee5654c4c715e4 /setup.py
parent44da004bddbcfb5124b01abc9fc85aa73f2141e2 (diff)
setup: include ujson as required dependency
also update psutil version constraint Signed-off-by: Rui Chen <rui@chenrui.dev>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9344d0b0..a818ade1 100755
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,16 @@ def get_data_files():
def get_install_requires():
- requires = ['psutil>=5.3.0', 'defusedxml', 'future', 'packaging']
+ requires = [
+ 'psutil>=5.6.7',
+ 'defusedxml',
+ 'packaging',
+ 'future; python_version < "3.0"',
+ 'ujson<3; python_version < "3.0"',
+ 'ujson<4; python_version >= "3.5" and python_version < "3.6"',
+ 'ujson<5; python_version >= "3.6" and python_version < "3.7"',
+ 'ujson>=5.4.0; python_version >= "3.7"',
+ ]
if sys.platform.startswith('win'):
requires.append('bottle')
requires.append('requests')