summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornicolargo <nicolas@nicolargo.com>2023-03-12 09:44:43 +0100
committernicolargo <nicolas@nicolargo.com>2023-03-12 09:44:43 +0100
commitdb4bd0d136707ffe58620825aa147eff1d3640bf (patch)
tree8a4676eb7cbdc2634ae4062bf0ed46f47855296c /setup.py
parent70aa46d4a0b6ad8ff6f4aa02eaad1d938ab891e3 (diff)
parent43291246de969abef0acfcc9fe1841cd0ac95d9c (diff)
Merge from develop
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index fec0ccd7..a8191091 100755
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,16 @@ def get_data_files():
def get_install_requires():
- requires = ['psutil>=5.3.0', 'defusedxml', 'future', 'packaging']
+ requires = [
+ 'psutil>=5.6.7',
+ 'defusedxml',
+ 'packaging',
+ 'future; python_version < "3.0"',
+ 'ujson<3; python_version < "3.0"',
+ 'ujson<4; python_version >= "3.5" and python_version < "3.6"',
+ 'ujson<5; python_version >= "3.6" and python_version < "3.7"',
+ 'ujson>=5.4.0; python_version >= "3.7"',
+ ]
if sys.platform.startswith('win'):
requires.append('bottle')
requires.append('requests')
@@ -127,13 +136,11 @@ setup(
'License :: OSI Approved :: GNU Lesser General Public License v3 (LGPLv3)',
'Operating System :: OS Independent',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Topic :: System :: Monitoring'
]
)