summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornicolargo <nicolas@nicolargo.com>2024-05-12 18:26:26 +0200
committernicolargo <nicolas@nicolargo.com>2024-05-12 18:26:26 +0200
commit147f8a4de46c9e6e65ab7ff901cf576c671637d8 (patch)
tree36e103d2a98e7f2aa3ea59449a4df8c01838c8b2 /setup.py
parentd9056e6027082b43e4437bbdead34e7871ffd59f (diff)
Correct issue with deps in Pypi
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index ee5b05d8..ad88e147 100755
--- a/setup.py
+++ b/setup.py
@@ -8,6 +8,11 @@ from io import open
from setuptools import setup, Command
+# Predication warning
+# Glances version 4 will only be compatible with Python 3.7 and above
+if sys.version_info < (3, 7):
+ print('WARNING: Glances version 4 will only be compatible with Python 3.7 and above.')
+
if sys.version_info < (3, 8):
print('Glances requires at least Python 3.8 to run.')
sys.exit(1)
@@ -34,14 +39,11 @@ def get_data_files():
return data_files
+with open('requirements.txt') as f:
+ required = f.read().splitlines()
def get_install_requires():
- requires = [
- 'psutil>=5.6.7',
- 'defusedxml',
- 'packaging',
- 'ujson>=5.4.0',
- ]
+ requires = required
if sys.platform.startswith('win'):
requires.append('fastapi')
requires.append('uvicorn')
@@ -54,7 +56,7 @@ def get_install_requires():
def get_install_extras_require():
extras_require = {
'action': ['chevron'],
- 'browser': ['zeroconf==0.131.0'],
+ 'browser': ['zeroconf>=0.19.1'],
'cloud': ['requests'],
'containers': ['docker>=6.1.1', 'python-dateutil', 'six', 'podman', 'packaging'],
'export': ['bernhard', 'cassandra-driver', 'elasticsearch', 'graphitesender',