summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBharath Vignesh J K <52282402+RazCrimson@users.noreply.github.com>2024-05-17 02:23:53 +0530
committerBharath Vignesh J K <52282402+RazCrimson@users.noreply.github.com>2024-05-17 03:36:53 +0530
commitd392caf6f65286f6b6a38b0f5b28adb391c28ac8 (patch)
tree423385d1fb491594575ff2c8451561c9ed096bce /pyproject.toml
parent9890749d8101ee94cad1254e0349bde0ff3b2722 (diff)
chg: ruff - isort fixes
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 15 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 30158d4d..5b6464c3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -12,7 +12,20 @@ quote-style = "preserve"
[tool.ruff.lint]
# Enable pycodestyle (`E`) and Pyflakes (`F`) codes by default.
-select = ["E", "F"]
+select = [
+# "C90", # mccabe
+ "E", # pycodestyle
+ "F", # Pyflakes
+ "I", # isort
+# "N", # pep8-naming
+ "W", # pycodestyle
+# "UP", # pyupgrde
+# "C4", # flake8-comprehensions
+# "RET", # flake8-return
+# "FBT", # flake8-boolean-trap
+# "RUF", # Ruff-specific rules
+# "PERF", # Perflint
+]
ignore = []
# Allow autofix for all enabled rules (when `--fix`) is provided.
@@ -50,4 +63,4 @@ dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
[tool.ruff.lint.mccabe]
# Unlike Flake8, default to a complexity level of 10.
-max-complexity = 10 \ No newline at end of file
+max-complexity = 18 \ No newline at end of file