summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBharath Vignesh J K <52282402+RazCrimson@users.noreply.github.com>2024-05-16 17:31:42 +0530
committerBharath Vignesh J K <52282402+RazCrimson@users.noreply.github.com>2024-05-17 02:10:09 +0530
commitacb5ef585f62d506f6f0345b306fc6bc9c15fef4 (patch)
tree0565f3b619694de9f690a070a1605b8017182e32 /pyproject.toml
parent396e78c415bb5875ea9767bd82f5ec1abca9b3b9 (diff)
chore: ruff cleanup
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 10 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 4fe27079..30158d4d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,6 +4,13 @@ skip-string-normalization = true
exclude = '\./glances/outputs/static/*'
[tool.ruff]
+line-length = 120
+target-version = "py38"
+
+[tool.ruff.format]
+quote-style = "preserve"
+
+[tool.ruff.lint]
# Enable pycodestyle (`E`) and Pyflakes (`F`) codes by default.
select = ["E", "F"]
ignore = []
@@ -34,18 +41,13 @@ exclude = [
"dist",
"node_modules",
"venv",
- "docs"
+ "docs",
+ "./glances/outputs/static/*"
]
-# Same as Black.
-line-length = 120
-
# Allow unused variables when underscore-prefixed.
dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
-# Assume Python 3.11
-target-version = "py311"
-
-[tool.ruff.mccabe]
+[tool.ruff.lint.mccabe]
# Unlike Flake8, default to a complexity level of 10.
max-complexity = 10 \ No newline at end of file