summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2022-09-19 08:58:45 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2022-09-19 08:58:45 +0800
commit946806e7390799807361562b038fb12eeb2ddf11 (patch)
treea084de5aae63f56ddb28ee8d61d63f438466205f /Cargo.toml
parent7fe68ead0222467092f67d49855655faf6d61ee4 (diff)
parenta734efb7e332de6a3bb4911e72463e4f6fc342e1 (diff)
chore: replace `colored` dependency with `owo-colors`.
The latter provide zero-allocation coloring in the terminal and may improve compile times a little.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8ba4bed..d0c31d3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,7 +27,6 @@ itertools = "0.10.0"
num_cpus = "1.10.0"
filesize = "0.2.0"
anyhow = "1.0.31"
-colored = "2.0.0"
trash = { version = "2.1.5", optional = true, default-features = false, features = ["coinit_apartmentthreaded"] }
# 'tui' related
@@ -37,6 +36,7 @@ tui = { version = "0.19.0", optional = true, default-features = false }
tui-react = { version = "0.19.0", optional = true }
open = { version = "3.0", optional = true }
wild = "2.0.4"
+owo-colors = "3.5.0"
[target.'cfg(all(target_os = "macos", target_arch = "aarch64"))'.dependencies]
sysinfo = { version = "0.23.2", default-features = false }