summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2020-07-06 14:32:07 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2020-07-06 14:32:07 +0800
commit464829e11f5d6d63019ec167e2e1b1b7c0061f0a (patch)
tree32a40d4297093f964747387e5e0c9229e9544ab9 /Cargo.toml
parentd0c362ae0f0f7ff4d49d899591c6cbb205e6b191 (diff)
Make interactive mode optional, allow selection of backend for windows, unix
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 14 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1bd29c4..9767861 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,25 +9,33 @@ description = "A tool to conveniently learn about the disk usage of directories,
license = "MIT"
include = ["src/**/*", "Cargo.*", "LICENSE", "README.md", "CHANGELOG.md", "!**/*_test/*"]
+[features]
+default = ["tui-crossplatform"]
+tui-unix = ["crosstermion/tui-react-termion", "tui-shared"]
+tui-crossplatform = ["crosstermion/tui-react-crossterm", "tui-shared"]
+
+tui-shared = ["crosstermion/input-thread-flume", "tui", "tui-react", "open", "unicode-segmentation"]
+
[dependencies]
structopt = "0.3.15"
jwalk = "0.5.0"
byte-unit = "4"
atty = "0.2.11"
-tui = "0.9.1"
petgraph = "0.5"
itertools = "0.9.0"
-open = "1.2.2"
-log = "0.4.6"
-tui-react = "0.4"
num_cpus = "1.10.0"
-unicode-segmentation = "1.3.0"
filesize = "0.2.0"
flume = {version = "0.7.1", default-features = false}
anyhow = "1.0.31"
-crosstermion = { version = "0.1.3", default-features = false, features = ["tui-react-crossterm", "input-thread-flume"]}
colored = "1.9.3"
+# 'tui' related
+unicode-segmentation = { version = "1.3.0", optional = true }
+crosstermion = { optional = true, version = "0.1.3", default-features = false }
+tui = { version = "0.9.1", optional = true }
+tui-react = { version = "0.4", optional = true }
+open = { version = "1.2.2", optional = true }
+
[[bin]]
name="dua"
path="src/main.rs"