summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2020-07-11 22:13:13 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2020-07-11 22:13:13 +0800
commitba78ae433d1ea905bf1efd751cec34901e509caa (patch)
tree2cf10628e36a875b1ae0352967dd6ed8178a9885 /Cargo.toml
parent901d29df066e8974b272c742ca4f9a9c7aa49dbc (diff)
Replace flume with just std::sync::mpsc
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f0ecf0b..960c647 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,7 +14,7 @@ default = ["tui-crossplatform"]
tui-unix = ["crosstermion/tui-react-termion", "tui-shared"]
tui-crossplatform = ["crosstermion/tui-react-crossterm", "tui-shared"]
-tui-shared = ["crosstermion/input-thread-flume", "tui", "tui-react", "open", "unicode-segmentation"]
+tui-shared = ["tui", "tui-react", "open", "unicode-segmentation"]
[dependencies]
structopt = "0.3.15"
@@ -25,13 +25,12 @@ petgraph = "0.5"
itertools = "0.9.0"
num_cpus = "1.10.0"
filesize = "0.2.0"
-flume = {version = "0.7.1", default-features = false}
anyhow = "1.0.31"
colored = "1.9.3"
# 'tui' related
unicode-segmentation = { version = "1.3.0", optional = true }
-crosstermion = { optional = true, version = "0.1.3", default-features = false }
+crosstermion = { optional = true, version = "0.2.0", default-features = false }
tui = { version = "0.9.1", optional = true, default-features = false }
tui-react = { version = "0.4", optional = true }
open = { version = "1.2.2", optional = true }