summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2020-07-06 10:44:23 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2020-07-06 10:44:23 +0800
commit98f850a1ccd30618620a7d78999899c24463238a (patch)
treea1fe3d9754d673c9fd90ab5e042da68879148e74 /Cargo.toml
parent4b59c36ca8c53e63dd74fc0b3179a4ed9de2f60d (diff)
Use crosstermion to create a terminal with the corresponding backend
The only question left is how to conform colors.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fec0328..85b32f8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,7 +20,7 @@ petgraph = "0.5"
itertools = "0.9.0"
open = "1.2.2"
log = "0.4.6"
-tui-react = { path = "./tui-react", version = "0.4" }
+tui-react = { version = "0.4" }
num_cpus = "1.10.0"
unicode-segmentation = "1.3.0"
filesize = "0.2.0"
@@ -28,7 +28,7 @@ flume = {version = "0.7.1", default-features = false}
anyhow = "1.0.31"
[target.'cfg(windows)'.dependencies]
-crosstermion = { version = "0.1.3", features = ["tui-react-crossterm", "input-thread-flume"]}
+crosstermion = { version = "0.1.3", default-features = false, features = ["tui-react-crossterm", "input-thread-flume"]}
[target.'cfg(unix)'.dependencies]
crosstermion = { version = "0.1.3", default-features = false, features = ["tui-react-termion", "input-thread-flume"]}