summaryrefslogtreecommitdiffstats
path: root/doc/paper/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'doc/paper/shell.nix')
-rw-r--r--doc/paper/shell.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/paper/shell.nix b/doc/paper/shell.nix
new file mode 100644
index 0000000..41687e7
--- /dev/null
+++ b/doc/paper/shell.nix
@@ -0,0 +1,28 @@
+{ pkgs ? (import <nixpkgs> {}) }:
+
+let
+ texlive = pkgs.texlive;
+in
+pkgs.mkShell rec {
+ buildInputs = [
+ pkgs.svgbob
+
+ (texlive.combine {
+ inherit (texlive)
+ scheme-basic
+ collection-langenglish
+ collection-fontsextra
+ collection-fontsrecommended
+ metafont
+ algorithms
+ cm-super
+
+ cite
+ citeall
+ citeref
+ xcolor
+ ;
+ })
+ ];
+}
+