summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDan Davison <dandavison7@gmail.com>2021-11-14 14:15:51 -0500
committerDan Davison <dandavison7@gmail.com>2021-11-22 13:18:15 -0500
commit07892bc572a92bca8e3fec3d1b0ba717d80cc096 (patch)
tree8da5b5e842d95291edd2bf29b6b1b2dce345fbb1 /Cargo.toml
parentce6258d1b85f9a4624a430cc2aac2a510aabb08a (diff)
Handle grep output
- Handle standard filepath:code and filepath:line_number:code output as produced by `git grep`, `rg -H`, `grep -H`, etc (with -n for line numbers). - Retain the match highlighting as produced by the grep tool, and expose it in delta's color output styled with grep-match-style. (Note that --color=always is needed to retain the color if piping into delta, but not for `git grep` when delta is configured as git's pager) - Special handling of -p, and -W options of `git grep`: these display the function context in which the matches occur. - `navigate` keybindings jump between match function contexts under `git grep -p` and between matching lines under `git grep -W`. Thanks @zachriggle for the proposal. Fixes #769
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9ea4d211..8f1f8602 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,6 +32,8 @@ lazy_static = "1.4"
palette = "0.6.0"
pathdiff = "0.2.1"
regex = "1.4.6"
+serde = { version = "1.0.118", features = ["derive"] }
+serde_json = "1.0.70"
shell-words = "1.0.0"
smol_str = "0.1.18"
structopt = "0.3.25"