summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authornickelc <constantin.nickel@gmail.com>2023-07-09 00:00:36 +0200
committerGitHub <noreply@github.com>2023-07-08 18:00:36 -0400
commit915662f5da4d8058c0bc6496a502c4b4ce28fe7d (patch)
tree904c4cccc03f4cf38c9282250b1fd94ac2db73cb /Cargo.toml
parentff5fd061f4dfc9b00f80aada705de192a5524ed5 (diff)
Replace usage of the `atty` crate with `std::io::IsTerminal` trait (#1465)
Rust 1.70 stabilized the `IsTerminal` trait and the newest version of `grep-cli` crate depending on it, makes it possible to remove the unmaintained `atty` crate from the build. ``` Crate: atty Version: 0.2.14 Warning: unsound Title: Potential unaligned read Date: 2021-07-04 ID: RUSTSEC-2021-0145 URL: https://rustsec.org/advisories/RUSTSEC-2021-0145 ```
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2b36a6d0..d4403865 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,7 +21,6 @@ chrono-humanize = "0.2.2"
ansi_colours = "1.2.1"
ansi_term = "0.12.1"
anyhow = "1.0.70"
-atty = "0.2.14"
bitflags = "2.2.1"
box_drawing = "0.1.2"
bytelines = "=2.2.2" # Pin version until its tokio and futures dependencies are optional.
@@ -29,7 +28,7 @@ clap = { version = "4.1.11", features = ["derive", "help", "usage", "error-conte
console = "0.15.0"
ctrlc = "3.2.5"
dirs = "5.0.1"
-grep-cli = "0.1.7"
+grep-cli = "0.1.8"
itertools = "0.10.5"
lazy_static = "1.4"
palette = "0.7.2"