summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authornickelc <constantin.nickel@gmail.com>2023-03-03 12:19:07 +0100
committerGitHub <noreply@github.com>2023-03-03 06:19:07 -0500
commit420b1acea1f977aa45712ca22309fad20a5a6018 (patch)
tree3cd4f5b2bf77e82f67a9ddd4a747e0ed831ed404 /Cargo.toml
parent590d5fa2ebfe46887bbe1f994ca98fc33d6d3462 (diff)
Update `clap` to 4.1 (#1322)
* Update to clap 4 * Add help, usage, error-context features to clap * Add wrap_help clap feature * Remove DeriveDisplayOrder as it is now default * Update ValueSource using statement * Update #[clap(...)] to #[command(...)] * Update #[clap(...)] to #[arg(...)] * Update #[structopt(...)] to #[arg(...)] * Remove value_parser because it is now default * Return option & argument names as `String` due to lifetime issues * Remove leading hyphens from arguments long definition Leading hyphens are no longer accepted. * Argument names are derived from field names and `snake_case` * `help` & `version` are no longer added automatically * Update `clap` to 4.1.8 --------- Co-authored-by: tjquillan <tjquillan@gmail.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 18f9e9c3..d144542d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,7 +24,7 @@ atty = "0.2.14"
bitflags = "1.3.2"
box_drawing = "0.1.2"
bytelines = "2.4.0"
-clap = { version = "3.2.8", features = ["derive"] }
+clap = { version = "4.1.8", features = ["derive", "help", "usage", "error-context", "wrap_help"] }
console = "0.15.0"
ctrlc = "3.2.2"
dirs-next = "2.0.0"