summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDan Davison <dandavison7@gmail.com>2022-01-15 20:59:57 -0500
committerGitHub <noreply@github.com>2022-01-15 20:59:57 -0500
commitf498544dfd0ffe7d1a3edbfef65a5067ad50091d (patch)
tree9f927d7c06093f60bf36a6c0abd781c41f00e39e /Cargo.toml
parenta2038166d64f5cef5c5436590560d08467ca596d (diff)
structopt to clap (#889)
Replace structopt with clap Fixes #888 * Drop tests of deprecated options They were failing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6f46bcf1..845e81d1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,6 +23,7 @@ atty = "0.2.14"
bitflags = "1.3.2"
box_drawing = "0.1.2"
bytelines = "2.2.2"
+clap = { version = "3.0.5", features = ["derive"] }
console = "0.15.0"
ctrlc = "3.2.1"
dirs-next = "2.0.0"
@@ -36,7 +37,6 @@ serde = { version = "1.0.118", features = ["derive"] }
serde_json = "1.0.70"
shell-words = "1.0.0"
smol_str = "0.1.21"
-structopt = "0.3.25"
unicode-segmentation = "1.8.0"
unicode-width = "0.1.9"
vte = "0.10.1"