summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDan Davison <dandavison7@gmail.com>2022-05-13 11:59:45 -0400
committerDan Davison <dandavison7@gmail.com>2022-05-13 12:21:16 -0400
commita8c79aa9de00e61dd2a92ac53923984391c461ae (patch)
tree95981c960f3535b2d606a4d2b18ca9c393579430 /Cargo.toml
parenta53dc02c4a81c6ff2423cb7e8f2397a20437a918 (diff)
Update bat, git2, and syntect
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 3 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ecb7f191..0ed99402 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ name = "delta"
path = "src/main.rs"
[dependencies]
-bat = "0.20.0"
+bat = "0.21.0"
chrono = "0.4.19"
chrono-humanize = "0.2.1"
ansi_colours = "1.0.4"
@@ -38,21 +38,17 @@ serde = { version = "1.0.118", features = ["derive"] }
serde_json = "1.0.70"
shell-words = "1.0.0"
smol_str = "0.1.21"
+syntect = "5.0.0"
unicode-segmentation = "1.9.0"
unicode-width = "0.1.9"
vte = "0.10.1"
xdg = "2.4.1"
[dependencies.git2]
-version = "0.13.25"
+version = "0.14.0"
default-features = false
features = []
-[dependencies.syntect]
-version = "4.6.0"
-default-features = false
-features = ["parsing", "assets", "yaml-load", "dump-load", "regex-onig"]
-
[dependencies.sysinfo]
version = "0.23.0"
# no default features to disable the use of threads