summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authornickelc <constantin.nickel@gmail.com>2023-03-05 21:07:25 +0100
committerGitHub <noreply@github.com>2023-03-05 15:07:25 -0500
commita8446c53bb32fa7c2d1fc4cddb4720b737b2cc8a (patch)
treed8cb7c6481536d1efd08fe9cf244e924c8733519 /Cargo.toml
parenta30aa5f88fb707953e2c78e9f888d147d03a3fe3 (diff)
Update dependencies & switch back to the `dirs` crate (#1325)
* Update direct dependencies * Update transient dependencies * Switch back to `dirs` crate The `dirs`/`dirs-sys` repositories are unarchived and the crates are maintained again, while `dirs-next` crates aren't.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml34
1 files changed, 17 insertions, 17 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d144542d..69567972 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,10 +15,10 @@ name = "delta"
path = "src/main.rs"
[dependencies]
-bat = { version = "0.21.0", default-features = false, features = ["regex-onig"] }
-chrono = "0.4.19"
-chrono-humanize = "0.2.1"
-ansi_colours = "1.0.4"
+bat = { version = "0.22.1", default-features = false, features = ["regex-onig"] }
+chrono = "0.4.23"
+chrono-humanize = "0.2.2"
+ansi_colours = "1.2.1"
ansi_term = "0.12.1"
atty = "0.2.14"
bitflags = "1.3.2"
@@ -26,22 +26,22 @@ box_drawing = "0.1.2"
bytelines = "2.4.0"
clap = { version = "4.1.8", features = ["derive", "help", "usage", "error-context", "wrap_help"] }
console = "0.15.0"
-ctrlc = "3.2.2"
-dirs-next = "2.0.0"
-grep-cli = "0.1.6"
-itertools = "0.10.3"
+ctrlc = "3.2.5"
+dirs = "4.0.0"
+grep-cli = "0.1.7"
+itertools = "0.10.5"
lazy_static = "1.4"
-palette = "0.6.0"
+palette = "0.6.1"
pathdiff = "0.2.1"
-regex = "1.5.5"
-serde = { version = "1.0.118", features = ["derive"] }
-serde_json = "1.0.82"
+regex = "1.7.1"
+serde = { version = "1.0.152", features = ["derive"] }
+serde_json = "1.0.93"
shell-words = "1.0.0"
-smol_str = "0.1.23"
+smol_str = "0.1.24"
syntect = "5.0.0"
-unicode-segmentation = "1.9.0"
-unicode-width = "0.1.9"
-vte = "0.10.1"
+unicode-segmentation = "1.10.1"
+unicode-width = "0.1.10"
+vte = "0.11.0"
xdg = "2.4.1"
[dependencies.git2]
@@ -50,7 +50,7 @@ default-features = false
features = []
[dependencies.sysinfo]
-version = "0.24.5"
+version = "0.28.2"
# no default features to disable the use of threads
default-features = false
features = []