summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDan Davison <dandavison7@gmail.com>2021-12-11 15:31:34 -0500
committerGitHub <noreply@github.com>2021-12-11 15:31:34 -0500
commit69c7aaa28fdda955cf430134170e3a533970cc0f (patch)
tree55d68bb4f93e2c63d77f30d0ede49d8d643ab853 /Cargo.toml
parent5c1612ec0ad328249a611933cf7d13b05a99680a (diff)
Do not query CPU data when querying process data (#845)
* Do not query CPU data when querying process data Fixes #839 Ref https://github.com/GuillaumeGomez/sysinfo/issues/632 * Update branch of sysinfo * Update upstream sysinfo commit Ref https://github.com/GuillaumeGomez/sysinfo/pull/636 * Point sysinfo at an explicit commit rather than a symbolic branch name commit d647acfbf216848a8237e1f9251b2c48860a547f Merge: 989ac6c 67a586c Author: Guillaume Gomez <guillaume1.gomez@gmail.com> Date: 2 hours ago Merge pull request #636 from GuillaumeGomez/update-if-needed Only update processors if needed
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1d44112f..355a9408 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -53,7 +53,8 @@ default-features = false
features = ["parsing", "assets", "yaml-load", "dump-load", "regex-onig"]
[dependencies.sysinfo]
-version = "0.20.5"
+git = "https://github.com/GuillaumeGomez/sysinfo"
+commit = "d647acfbf216848a8237e1f9251b2c48860a547f"
# no default features to disable the use of threads
default-features = false
features = []