summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authornickelc <constantin.nickel@gmail.com>2023-04-26 17:04:15 +0200
committerGitHub <noreply@github.com>2023-04-26 11:04:15 -0400
commit12fd54e7a81c016fc54f46537e2acebd5e4f45c6 (patch)
tree974ef6817d4fc979b726d8f11d5103403a4601d5 /Cargo.toml
parentd89b357ad3f28075d835280ab376d3351eefe7a0 (diff)
Downgrade and pin the `bytelines` crate (#1378)
The versions 2.3+ added support for Tokio's `AsyncBufRead` trait and futures' `Stream` trait without making the new dependencies optional. By downgrading `bytelines`, the compilation time can be reduced. ``` $ cargo up -p bytelines --precise 2.2.2 Updating bytelines v2.4.0 -> v2.2.2 Removing bytes v1.4.0 Removing futures v0.3.26 Removing futures-channel v0.3.26 Removing futures-core v0.3.26 Removing futures-executor v0.3.26 Removing futures-io v0.3.26 Removing futures-macro v0.3.26 Removing futures-sink v0.3.26 Removing futures-task v0.3.26 Removing futures-util v0.3.26 Removing pin-project-lite v0.2.9 Removing pin-utils v0.1.0 Removing slab v0.4.8 Removing tokio v1.26.0 ```
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a5dcb97e..fb75c24d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,7 +23,7 @@ ansi_term = "0.12.1"
atty = "0.2.14"
bitflags = "2.2.1"
box_drawing = "0.1.2"
-bytelines = "2.4.0"
+bytelines = "=2.2.2" # Pin version until its tokio and futures dependencies are optional.
clap = { version = "4.1.8", features = ["derive", "help", "usage", "error-context", "wrap_help"] }
console = "0.15.0"
ctrlc = "3.2.5"