summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDan Davison <dandavison7@gmail.com>2020-05-09 12:32:01 -0400
committerDan Davison <dandavison7@gmail.com>2020-05-16 09:04:38 -0400
commit79979c272d6daa876ffb3dbad7a6550c22155c8c (patch)
tree30baf82bd2892ffb73bfd3f6dab6ce21b6ae6ebd /Cargo.toml
parent21537d6eb8f07d6c1e71c757fb8f0fd583449219 (diff)
Hunk highlighting test and refactoring
- New command-line option --syntax highlight to select which category of hunk lines to be syntax highlighted. --highlight-removed is now deprecated. - New hunk highlighting test tests syntax highlighting and background colors - Refactor: construction of style modifiers for config struct - Refactor: compute minus and plus foreground style sections separately - Refactor: foreground style logic - Refactor: rearrange style modifier construction for config - Refactor: change variable name: => highlight_minus_lines - Refactor: clean up --color-only config implementation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 96171ec8..15c9407c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,12 +17,15 @@ path = "src/main.rs"
[dependencies]
ansi_colours = "1.0.1"
+ansi-parser = "0.6.5"
ansi_term = "0.12.1"
atty = "0.2.14"
+bit-set = "0.5.2"
box_drawing = "0.1.2"
bytelines = "2.2.2"
console = "0.11.2"
dirs = "2.0"
+itertools = "0.9.0"
lazy_static = "1.4"
regex = "1.2.1"
shell-words = "0.1.0"