summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorest31 <MTest31@outlook.com>2020-04-27 20:51:52 +0200
committerDan Davison <dandavison7@gmail.com>2020-04-27 18:48:12 -0400
commit4e3137050294829d5f7ce94bb4b22c4a2cb59b79 (patch)
tree3a7c92b434e15a9045cafbcfc273f302d40cc896 /Cargo.toml
parentf50662cf32ec13d24caab40adb43303dc29589e1 (diff)
Remove some unused syntect features
The default list of syntect features is: default = ["default-onig"] default-onig = ["parsing", "assets", "html", "yaml-load", "dump-load", "dump-create", "regex-onig"]
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 105501ee..3cad4b20 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,10 +26,14 @@ lazy_static = "1.4"
regex = "1.2.1"
shell-words = "0.1.0"
structopt = "0.2.18"
-syntect = "4.1.0"
unicode-segmentation = "1.3.0"
unicode-width = "0.1.6"
+[dependencies.syntect]
+version = "4.1.0"
+default-features = false
+features = ["parsing", "assets", "yaml-load", "dump-load", "regex-onig"]
+
[dependencies.error-chain]
version = "0.12.1"
default-features = false