summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 16 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b460961..149e191 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,8 +1,19 @@
[package]
-name = "daglib"
-version = "0.1.0"
-authors = ["Matthias Beyer <mail@beyermatthias.de>"]
-edition = "2018"
+name = "daglib"
+version = "0.1.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+edition = "2021"
+description = "Generic async DAG library"
+
+license = "MPL-2.0"
+repository = "https://github.com/matthiasbeyer/daglib"
+documentation = "https://docs.rs/daglib"
[dependencies]
-futures = "0.1"
+async-trait = "0.1"
+futures = "0.3"
+thiserror = "1"
+
+[dev-dependencies]
+tokio-test = "0.4"
+