summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-04 13:18:23 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-04 13:18:35 +0200
commitfb364c1ff338e7a67d717b77d431937888d8c009 (patch)
tree0698dbd412322ec9d2c09cf599ef1fe863be9c0e /Cargo.toml
parent2d25173aeafe9357f7cbd5c1edf6225d9ccf1114 (diff)
Import rewrite from distrox repository
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 15 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b460961..fafb950 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,8 +1,18 @@
[package]
-name = "daglib"
-version = "0.1.0"
-authors = ["Matthias Beyer <mail@beyermatthias.de>"]
-edition = "2018"
+name = "daglib"
+version = "0.1.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+edition = "2018"
+description = "Generic async DAG library"
[dependencies]
-futures = "0.1"
+# TODO: Replace with thiserror
+anyhow = "1"
+
+async-trait = "0.1"
+futures = "0.3"
+tokio = { version = "1", features = ["full"] }
+
+[dev-dependencies]
+tokio-test = "0.4"
+