summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-03-04 19:49:08 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-03-04 19:49:09 +0100
commit5a2478c242341d94e2b6ad253d09a738a66cfb99 (patch)
treebb9c773ec304b51c8dc8f64e5e88ef6dfd27273d /Cargo.toml
parentbf09a730d44cb72f483dab04163dd75f2b9d1746 (diff)
Fix test failure
As reported in https://github.com/hjson/hjson-rust/issues/23 the issue of the failing tests is the serde_hjson crate. The problem can be prevented (as reported by https://github.com/hjson/hjson-rust/issues/23#issuecomment-775520018) by disabling the default features of the crate (namingly preservation of key order). This commit disables the default features of serde_hjson to fix our tests. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 98a1383..f0f75b6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,7 +28,7 @@ nom = "5.0.0"
toml = { version = "0.5", optional = true }
serde_json = { version = "1.0.2", optional = true }
yaml-rust = { version = "0.4", optional = true }
-serde-hjson = { version = "0.9", optional = true }
+serde-hjson = { version = "0.9", default-features = false, optional = true }
rust-ini = { version = "0.13", optional = true }
[dev-dependencies]