summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRyan Leckey <leckey.ryan@gmail.com>2017-01-26 19:02:13 -0800
committerRyan Leckey <leckey.ryan@gmail.com>2017-01-26 19:02:13 -0800
commit589036c19409c7626a5bafda5af96c2fbc6a7de5 (patch)
tree9f4e09809df7c200c3d60b619c7eea9b91e6d70c /Cargo.toml
parentd7ad51c8851fe3c845569760935fae1828e859b5 (diff)
Refactor the file source to allow for N formats; implement JSON.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cb18d51..7aef758 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,5 +3,10 @@ name = "config"
version = "0.1.0"
authors = ["Ryan Leckey <leckey.ryan@gmail.com>"]
+[features]
+default = ["toml"]
+json = ["serde_json"]
+
[dependencies]
-toml = "0.2.1"
+toml = { version = "0.2.1", optional = true }
+serde_json = { version = "0.9", optional = true }