summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-01-17 11:44:49 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-01-17 12:25:52 +0100
commit63a6fa0c43d885b5f367372c06c578548d0b6384 (patch)
tree4192b76c8aae7927b2a16766b7832df6c05626e1 /shell.nix
Initial import
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..f8cd701
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,27 @@
+{ ... }:
+
+let
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+in
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
+
+ cmake
+ curl
+ gcc
+ openssl
+ pkgconfig
+ which
+ ];
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+}
+
+