summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDenys Séguret <cano.petrole@gmail.com>2023-07-15 13:41:48 +0200
committerGitHub <noreply@github.com>2023-07-15 13:41:48 +0200
commitf6a2b25305c5aa7c150aa3584578296bfe40b926 (patch)
tree13d98ff073de6fe56b6ff606ca55ee2ff4af34fe /Cargo.toml
parent1975f88ce9de5074a1b9b22c31801bf62ecdc7fd (diff)
use clap 4 instead of clap 3 (#722)
* use clap 4 instead of clap 3 * use clap-help
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 161166a..fd1db93 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,7 +27,8 @@ base64 = "0.13"
bet = "1.0.2"
char_reader = "0.1"
chrono = "0.4"
-clap = { version = "3.2.1", features = ["derive"] }
+clap = { version = "4.3", features = ["derive", "cargo"] }
+clap-help = "0.1.0"
cli-log = "2.0"
crokey = "0.4.3"
crossbeam = "=0.8"
@@ -77,8 +78,8 @@ users = "0.11"
is_executable = "1.0.1"
[build-dependencies]
-clap = { version = "3.2.1", features = ["derive"] }
-clap_complete = "3.2.1"
+clap = { version = "4.3", features = ["derive", "cargo"] }
+clap_complete = "4.3"
[profile.dev]
debug = false