summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCanop <cano.petrole@gmail.com>2023-06-16 06:56:59 +0200
committerCanop <cano.petrole@gmail.com>2023-06-16 06:56:59 +0200
commit427b5044b6b6832e489a9aa4e2400d14515ea3dd (patch)
tree6818dc4d476d3a992257c1562d378f4619045937 /Cargo.toml
parentac9052bd9a322f42316dafdfd54d9c9638711808 (diff)
update dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 161bbe7..ba6494b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,7 +21,7 @@ clipboard = ["terminal-clipboard"]
kitty-csi-check = ["xterm-query"]
[dependencies]
-ahash = { version = "0.7", features = ["serde"] }
+ahash = { version = "0.8.3", features = ["serde"] }
ansi_colours = "1.0"
base64 = "0.13"
bet = "1.0.2"
@@ -29,7 +29,6 @@ char_reader = "0.1"
chrono = "0.4"
clap = { version = "3.2.1", features = ["derive"] }
cli-log = "2.0"
-coolor = { version = "0.5", features = ["crossterm"] }
crokey = "0.4.3"
crossbeam = "=0.8"
custom_error = "1.6"
@@ -42,7 +41,7 @@ glob = "0.3"
id-arena = "2.2.1"
image = "0.24"
include_dir = "0.7"
-lazy-regex = "2.3.1"
+lazy-regex = "2.5.0"
libc = "0.2"
memmap2 = "0.6"
once_cell = "1.7"
@@ -59,12 +58,12 @@ splitty = "1.0"
strict = "0.1.4"
syntect = { package = "syntect-no-panic", version = "4.6.1" } # see issue #485
tempfile = "3.2"
-termimad = "0.22.0"
+termimad = "0.23.1"
terminal-clipboard = { version = "0.4.0", optional = true }
terminal-light = "1.1.1"
toml = "0.5"
umask = "2.1.0"
-unicode-width = "0.1.8"
+unicode-width = "0.1.10"
which = "4.4.0"
xterm-query = { version = "0.1", optional = true }