summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 13 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 883a9fb3..20dbdf00 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -64,23 +64,20 @@ strip = false
[features]
battery = ["starship-battery"]
-gpu = ["nvidia"]
nvidia = ["nvml-wrapper"]
+gpu = ["nvidia"]
zfs = []
-# Including logging for debugging purposes.
+# Logging for debugging performance.
logging = ["fern", "log", "time/local-offset"]
-# The features we use on deploy. Logging is not included as that is primarily (for now) just for debugging locally.
-deploy = ["battery", "gpu", "zfs"]
-
-default = ["deploy"]
+default = ["battery", "gpu", "zfs"]
[dependencies]
anyhow = "1.0.75"
backtrace = "0.3.69"
cfg-if = "1.0.0"
-clap = { version = "4.4.11", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.4.14", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.27.0"
ctrlc = { version = "3.4.1", features = ["termination"] }
@@ -93,7 +90,9 @@ indexmap = "2.1.0"
itertools = "0.12.0"
kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.20", optional = true }
-nvml-wrapper = { version = "0.9.0", optional = true, features = ["legacy-functions"] }
+nvml-wrapper = { version = "0.9.0", optional = true, features = [
+ "legacy-functions",
+] }
regex = "1.10.2"
serde = { version = "=1.0.193", features = ["derive"] }
starship-battery = { version = "0.8.2", optional = true }
@@ -133,15 +132,17 @@ filedescriptor = "0.8.2"
[dev-dependencies]
assert_cmd = "2.0.12"
-cargo-husky = { version = "1.5.0", default-features = false, features = ["user-hooks"] }
+cargo-husky = { version = "1.5.0", default-features = false, features = [
+ "user-hooks",
+] }
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.4.11", features = ["default", "cargo", "wrap_help"] }
-clap_complete = "4.4.5"
+clap = { version = "4.4.14", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "4.4.6"
clap_complete_fig = "4.4.2"
clap_complete_nushell = "4.4.2"
-clap_mangen = "0.2.15"
+clap_mangen = "0.2.16"
[package.metadata.deb]
section = "utility"