summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ffc536a2..8220e719 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -100,19 +100,19 @@ sysinfo = "=0.30.12"
thiserror = "1.0.61"
time = { version = "0.3.36", features = ["formatting", "macros"] }
toml_edit = { version = "0.22.14", features = ["serde"] }
-tui = { version = "0.26.3", package = "ratatui" }
-unicode-ellipsis = "0.1.4"
+tui = { version = "0.27.0", package = "ratatui" }
+unicode-ellipsis = "0.2.0"
unicode-segmentation = "1.11.0"
unicode-width = "0.1.13"
# Used for logging.
fern = { version = "0.6.2", optional = true }
-log = { version = "0.4.21", optional = true }
+log = { version = "0.4.22", optional = true }
# These are just used for for schema generation.
schemars = { version = "0.8.21", optional = true }
-serde_json = { version = "1.0.117", optional = true }
-strum = { version = "0.26", features = ["derive"], optional = true }
+serde_json = { version = "1.0.118", optional = true }
+strum = { version = "0.26.3", features = ["derive"], optional = true }
[target.'cfg(unix)'.dependencies]
libc = "0.2.155"
@@ -136,7 +136,7 @@ windows = { version = "0.57.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.117" }
+serde_json = { version = "1.0.118" }
sysctl = { version = "0.5.5" }
filedescriptor = "0.8.2"
@@ -150,7 +150,7 @@ portable-pty = "0.8.1"
[build-dependencies]
clap = { version = "4.5.7", features = ["default", "cargo", "wrap_help", "derive"] }
-clap_complete = "4.5.5"
+clap_complete = "4.5.6"
clap_complete_nushell = "4.5.2"
clap_complete_fig = "4.5.1"
clap_mangen = "0.2.21"