summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2022-03-11 06:45:05 -0500
committerGitHub <noreply@github.com>2022-03-11 06:45:05 -0500
commitf2b8b4e8427996407b484c4a4ed9432519c9d3a5 (patch)
tree02dc3866ce71afeab52fe268459d9af5531779e3 /Cargo.toml
parent8087f0b636b94ff5763a3a5637dea9a343784bd7 (diff)
other: add manpage file to cargo deb config, move back to build script (#693)
Adds the asset for the manpage to cargo deb config. Also moves the generated manpage file to a .1.gz file. Also, moves back to a build script since that was causing some issues for the automatic Cargo.toml fields detection for manpage and completion generation. To prevent compilation from happening every time, and only in CI, we use an env var to avoid generation steps.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b45e9123..38f84ba7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,7 @@ description = "A customizable cross-platform graphical process/system monitor fo
documentation = "https://clementtsang.github.io/bottom/stable"
readme = "README.md"
default-run = "btm"
+build = "build.rs"
[[bin]]
name = "btm"
@@ -83,6 +84,10 @@ winapi = "0.3.9"
assert_cmd = "2.0"
predicates = "2.1"
+[build-dependencies]
+clap = { version = "3.1.6", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "3.1.1"
+clap_mangen = "0.1.2"
[package.metadata.deb]
section = "utility"
@@ -98,6 +103,11 @@ assets = [
"644",
],
[
+ "manpage/btm.1.gz",
+ "usr/share/man/man1/btm.1.gz",
+ "644",
+ ],
+ [
"completion/btm.bash",
"usr/share/bash-completion/completions/btm",
"644",