summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-03-02 00:03:54 -0500
committerGitHub <noreply@github.com>2023-03-02 00:03:54 -0500
commitf26d598410c63dd5fcf6ed10bdd4b56e75697390 (patch)
tree8d2ab7cc494663c4e4796c777ffbc4d53af3d4a0 /Cargo.toml
parente8ae1a265ad52c0ff28dc9edf8dcfe7bc0ed669d (diff)
refactor: migrate CPU from heim to sysinfo for all platforms (#1035)
* refactor: migrate CPU from heim to sysinfo for all platforms * fix windows and macos imports * simplify a bit of code * cleanup
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 3 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index af6033b1..d6ad9e9c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -108,22 +108,16 @@ unicode-width = "0.1.10"
libc = "0.2.124"
[target.'cfg(target_os = "linux")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = [
- "cpu",
- "disk",
- "memory",
- "net",
- "sensors",
-] }
+heim = { version = "0.1.0-rc.1", features = ["disk", "memory", "net", "sensors"] }
procfs = { version = "0.14.2", default-features = false }
smol = "1.2.5"
[target.'cfg(target_os = "macos")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory", "net"] }
+heim = { version = "0.1.0-rc.1", features = ["disk", "memory", "net"] }
mach2 = "0.4.1"
[target.'cfg(target_os = "windows")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory"] }
+heim = { version = "0.1.0-rc.1", features = ["disk", "memory"] }
windows = { version = "0.44.0", features = [
"Win32_System_Threading",
"Win32_Foundation",