summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2022-12-30 03:06:48 -0500
committerGitHub <noreply@github.com>2022-12-30 03:06:48 -0500
commitefcf2bde2961d9b820609b56ddc77c666cb3b5bb (patch)
tree254f335b722ee7ba354071d8f09c0a7f1b65e2ce /Cargo.toml
parent21a21b86c0bbfd02ae21e0602a02d1c30cb264fb (diff)
other: use custom time chart grid implementation (#937)
Pulls in the tui-rs grid logic so I can implement custom braille painting logic. We basically "flatten" the layering logic into a single layer by replacing resetting cells if the colour is different. This avoids the multiple allocations if we used multiple layers as intended with tui-rs. This gives us chart results similar to the current stable version, but with a flamegraph similar to the current master branch.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 20 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 27b01edf..da6993ef 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -128,9 +128,21 @@ clap_mangen = "0.1.6"
[package.metadata.deb]
section = "utility"
assets = [
- ["target/release/btm", "usr/bin/", "755"],
- ["LICENSE", "usr/share/doc/btm/", "644"],
- ["manpage/btm.1.gz", "usr/share/man/man1/btm.1.gz", "644"],
+ [
+ "target/release/btm",
+ "usr/bin/",
+ "755",
+ ],
+ [
+ "LICENSE",
+ "usr/share/doc/btm/",
+ "644",
+ ],
+ [
+ "manpage/btm.1.gz",
+ "usr/share/man/man1/btm.1.gz",
+ "644",
+ ],
[
"completion/btm.bash",
"usr/share/bash-completion/completions/btm",
@@ -141,7 +153,11 @@ assets = [
"usr/share/fish/vendor_completions.d/btm.fish",
"644",
],
- ["completion/_btm", "usr/share/zsh/vendor-completions/", "644"],
+ [
+ "completion/_btm",
+ "usr/share/zsh/vendor-completions/",
+ "644",
+ ],
]
extended-description = """