summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2021-08-19 22:16:44 -0400
committerGitHub <noreply@github.com>2021-08-19 22:16:44 -0400
commited07fbe1ccb4b4f27253b1a642d8a6a663bcbf6b (patch)
treec73687b81ab5c6549bd1063c57a60b4f84a1f685 /Cargo.toml
parent2c8aea9eef696ecec7d999d9da62ed8c5cb2a09c (diff)
other: Make the battery dependency/features optional (#570)
Allows disabling of the battery dependency through a feature flag. This also aims to disable all related features.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e7bdfe3b..ad710d62 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,12 +31,11 @@ opt-level = 3
codegen-units = 1
[features]
-default = ["fern", "log"]
+default = ["fern", "log", "battery"]
[dependencies]
anyhow = "1.0.40"
backtrace = "0.3.59"
-battery = "0.7.8"
chrono = "0.4.19"
crossterm = "0.18.2"
ctrlc = { version = "3.1.9", features = ["termination"] }
@@ -60,9 +59,10 @@ typed-builder = "0.9.0"
unicode-segmentation = "1.7.1"
unicode-width = "0.1"
-# For debugging only... disable on release builds with --no-default-target for no? TODO: Redo this.
+# For debugging only... disable on release builds with for now? TODO: Redo this.
fern = { version = "0.6.0", optional = true }
log = { version = "0.4.14", optional = true }
+battery = { version = "0.7.8", optional = true }
[target.'cfg(unix)'.dependencies]
libc = "0.2.86"