summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2021-10-17 21:33:07 -0400
committerGitHub <noreply@github.com>2021-10-17 21:33:07 -0400
commitea0c7b49b7f4f546f4c20997b6efeea253c8d078 (patch)
treee003782c49ac7d58328a7df90ff39e5e8ac613fd /Cargo.toml
parent6c157fe1ddde267a44d2bd0577291e39435c31bd (diff)
deps: bump deps, remove chrono (#600)
Bumps up some dependencies and removes chrono, switching to the time crate instead. One of side-effects of this change is that local time seems to not work (?)... so all logs are now in UTC. Oh well, this doesn't affect general user behaviour so I'm fine with it.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 05f24aa3..8d244573 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -36,7 +36,6 @@ default = ["fern", "log", "battery"]
[dependencies]
anyhow = "1.0.40"
backtrace = "0.3.59"
-chrono = "0.4.19"
crossterm = "0.18.2"
ctrlc = { version = "3.1.9", features = ["termination"] }
clap = "2.33"
@@ -53,6 +52,7 @@ serde = { version = "1.0.125", features = ["derive"] }
# Sysinfo is still used in Linux for the ProcessStatus
sysinfo = "0.18.2"
thiserror = "1.0.24"
+time = { version = "0.3.3", features = ["formatting", "local-offset", "macros"] }
toml = "0.5.8"
tui = { version = "0.14.0", features = ["crossterm"], default-features = false }
typed-builder = "0.9.0"
@@ -69,7 +69,7 @@ libc = "0.2.86"
[target.'cfg(target_os = "linux")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "net", "sensors"] }
-procfs = "0.10.1"
+procfs = { version = "0.11.0", default-features = false }
smol = "1.2.5"
[target.'cfg(target_os = "macos")'.dependencies]