summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-02-08 00:41:03 -0500
committerGitHub <noreply@github.com>2023-02-08 00:41:03 -0500
commite7b682a550e5d7b1c7a745c2a248703398e17202 (patch)
tree7d07da5132f186bb45a01d6f5246447dfa41fc76 /Cargo.toml
parent9fd8ce3151e4f6ad273a51fd4a40c72aca40c438 (diff)
other: add no-opt and flamegraph build profiles for convenience (#1014)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 14 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 87136f5f..48783b0b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -43,15 +43,22 @@ doc = true
[profile.dev.package."*"]
opt-level = 3 # Compile dependencies with optimizations on.
+[profile.no-opt]
+inherits = "dev"
+opt-level = 0
+
[profile.release]
-# debug = true # Might be nice to have a custom profile for flamegraphs.
-# strip = false
debug = 0
strip = "symbols"
lto = true
opt-level = 3
codegen-units = 1
+[profile.flamegraph]
+inherits = "release"
+debug = true
+strip = false
+
[features]
battery = ["starship-battery"]
gpu = ["nvidia"]
@@ -110,11 +117,6 @@ smol = "1.2.5"
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory", "net"] }
mach2 = "0.4.1"
-[dev-dependencies.cargo-husky]
-version = "1"
-default-features = false
-features = ["user-hooks"]
-
[target.'cfg(target_os = "windows")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory"] }
windows = { version = "0.44.0", features = ["Win32_System_Threading", "Win32_Foundation"] }
@@ -130,6 +132,11 @@ filedescriptor = "0.8.2"
assert_cmd = "2.0.4"
predicates = "2.1.1"
+[dev-dependencies.cargo-husky]
+version = "1"
+default-features = false
+features = ["user-hooks"]
+
[build-dependencies]
clap = { version = "3.2.2", features = ["default", "cargo", "wrap_help"] }
clap_complete = "3.2.4"