summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2021-09-23 19:13:13 -0400
committerGitHub <noreply@github.com>2021-09-23 19:13:13 -0400
commite20057b97c441db44c1bff048db5c1e9aebc14f0 (patch)
treeb296fdb04586a57288121a6a7bd155e5dd2621e0 /Cargo.toml
parentb853aef7525ad576b8d740b644e843312d8a46fe (diff)
ci: move winget/msi and deb gen to separate steps (#585)
Moves debian and winget/msi generation to a separate job, so it can run in parallel to the other jobs.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 7 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ecc72f9b..05f24aa3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -92,16 +92,20 @@ assets = [
["target/release/btm", "usr/bin/", "755"],
["LICENSE", "usr/share/doc/btm/", "644"],
[
- "completion/btm.bash",
+ "target/release/build/bottom-*/out/btm.bash",
"usr/share/bash-completion/completions/btm",
"644",
],
[
- "completion/btm.fish",
+ "target/release/build/bottom-*/out/btm.fish",
"usr/share/fish/vendor_completions.d/btm.fish",
"644",
],
- ["completion/_btm", "usr/share/zsh/vendor-completions/", "644"],
+ [
+ "target/release/build/bottom-*/out/_btm",
+ "usr/share/zsh/vendor-completions/",
+ "644",
+ ],
]
extended-description = """\
A cross-platform graphical process/system monitor with a customizable interface and a multitude of