summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClementTsang <34804052+ClementTsang@users.noreply.github.com>2023-02-07 04:24:14 -0500
committerClementTsang <34804052+ClementTsang@users.noreply.github.com>2023-02-07 04:24:14 -0500
commit9fd8ce3151e4f6ad273a51fd4a40c72aca40c438 (patch)
tree6b021b789176c43fac50a08038b9fae697fc9611 /Cargo.toml
parent88111de94127be3cb53399ac085d818a8bbbdb7e (diff)
other: compile dependencies in dev with optimizations
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8bc91018..87136f5f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -40,6 +40,9 @@ test = true
doctest = true
doc = true
+[profile.dev.package."*"]
+opt-level = 3 # Compile dependencies with optimizations on.
+
[profile.release]
# debug = true # Might be nice to have a custom profile for flamegraphs.
# strip = false