summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-03-03 00:06:19 -0500
committerGitHub <noreply@github.com>2023-03-03 00:06:19 -0500
commit8cc763cc1b9741349805fd658308cc34ddba2a4f (patch)
tree949fadbd8e64f9096ef03a027ab678e1778b3e83 /Cargo.toml
parentc2d94900f31305176781950278bc629d399f41f3 (diff)
refactor: migrate memory collection to sysinfo for all platforms (#1036)
* cleanup * refactor: remove heim memory code * add missing updates, remove heim memory feature * restrict export visibility * some refactoring, remove smol * gpu feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 94f8cfab..9fd83bca 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -108,16 +108,15 @@ unicode-width = "0.1.10"
libc = "0.2.124"
[target.'cfg(target_os = "linux")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = ["disk", "memory", "net", "sensors"] }
+heim = { version = "0.1.0-rc.1", features = ["disk", "net", "sensors"] }
procfs = { version = "0.15.1", default-features = false }
-smol = "1.2.5"
[target.'cfg(target_os = "macos")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = ["disk", "memory", "net"] }
+heim = { version = "0.1.0-rc.1", features = ["disk", "net"] }
mach2 = "0.4.1"
[target.'cfg(target_os = "windows")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = ["disk", "memory"] }
+heim = { version = "0.1.0-rc.1", features = ["disk"] }
windows = { version = "0.44.0", features = [
"Win32_System_Threading",
"Win32_Foundation",