summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2022-09-07 23:51:08 -0400
committerGitHub <noreply@github.com>2022-09-07 23:51:08 -0400
commit72189185b6723ecc3c837f08007752f9dd2a8151 (patch)
tree6d51ac8a36bc669d1b43c62b3c2a50137eebfd07 /Cargo.toml
parent46a2a3a52b837512280384d7b03e4718e504b4a6 (diff)
other: sort Cargo.toml (#802)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3a065a0a..aa678453 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,20 +52,25 @@ zfs = ["sysctl"]
anyhow = "1.0.57"
backtrace = "0.3.65"
cfg-if = "1.0.0"
-crossterm = "0.18.2"
-ctrlc = { version = "3.1.9", features = ["termination"] }
clap = { version = "3.1.12", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
+crossterm = "0.18.2"
+ctrlc = { version = "3.1.9", features = ["termination"] }
# const_format = "0.2.23"
dirs = "4.0.0"
+
+fern = { version = "0.6.1", optional = true }
futures = "0.3.21"
futures-timer = "3.0.2"
fxhash = "0.2.1"
indexmap = "1.8.1"
itertools = "0.10.3"
+log = { version = "0.4.16", optional = true }
+nvml-wrapper = { version = "0.7.0", optional = true }
once_cell = "1.5.2"
regex = "1.5.5"
serde = { version = "1.0.136", features = ["derive"] }
+starship-battery = { version = "0.7.9", optional = true }
sysinfo = "0.23.10"
thiserror = "1.0.30"
time = { version = "0.3.9", features = ["formatting", "macros"] }
@@ -75,11 +80,6 @@ typed-builder = "0.10.0"
unicode-segmentation = "1.9.0"
unicode-width = "0.1.9"
-fern = { version = "0.6.1", optional = true }
-log = { version = "0.4.16", optional = true }
-starship-battery = { version = "0.7.9", optional = true }
-nvml-wrapper = { version = "0.7.0", optional = true }
-
[target.'cfg(unix)'.dependencies]
libc = "0.2.124"
@@ -155,3 +155,4 @@ output = "bottom_x86_64_installer.msi"
version = "1"
default-features = false
features = ["user-hooks"]
+